Security vulnerability found on Lightning Network and node upgrade recommended

posted 3 months ago
Bitcoin’s Lightning Network, an experimental second-layer scaling solution built on top of the Bitcoin Network for quicker fund transfers, has been found to have a security vulnerability.

Rusty Russell, an Australian software programmer and a Bitcoin Lightning coder, tweeted Friday, saying that security issues have been discovered in “various Lightning projects which could cause loss of funds.” The coder has advised users to upgrade the following affected lightning nodes:

- Common vulnerabilities and exposures (CVE) -2019-12998 c-lightning < 0.7.1
- CVE-2019-12999 lnd < 0.7
- CVE-2019-13000 eclair <= 0.3
Tags: bitcoin, blockchain, news